User Tools

Site Tools


downloads
Advertisement

Firestorm Viewer Downloads For Second Life


IMPORTANT:
How to update Firestorm:

OpenSIM versions of FS do not have Havok. That only matters if you're uploading mesh objects and need to specify the mesh physics properties, or if you need to manipulate the region navmesh for pathfinding. The terms of the Havok license prohibit its use anywhere but Second Life, so it's not present in OpenSim versions. Furthermore, the Havok libraries are not currently available for 64-bit platforms.


Firestorm Viewer is certified to be free of viruses and malware.


Current Release

Firestorm 5.0.1 (52150) Release

“n/a” in the table below means “not available”; see the boxed note above.

Version 32/64-bit Grids Havok Level of Support Download
Windows
Windows
32-bit Havok
32 and 64 SL only X Full release Firestorm 5.0.1.52150 32 bit Windows setup.exe
SHA1 Checksum: 132FB193F9B0D6CFAA1448759FA59059432E3898
Windows
32-bit OpenSim
32 and 64 SL and other grids Full release Firestorm 5.0.1.52150OS 32 bit Windows setup.exe
SHA1 Checksum: 1C3E1E4DC875775BE7BBE8ED57B6B1893730A511
Windows
64-bit Havok
64-bit only SL only n/a n/a
Windows
64-bit OpenSim
64-bit only SL and other grids Full release Firestorm 5.0.1.52150OS 64 bit Windows Setup.exe
SHA1 Checksum: 3BAFBB700E48CFC3392B9F60416BB9FFEDAF594B
Mac
Mac
32-bit Havok
32 and 64 SL only X n/a n/a
Mac
32-bit OpenSim
32 and 64 SL and other grids n/a n/a
Mac
64-bit Havok
32 and 64 SL only n/a n/a
Mac
64-bit OpenSim
32 and 64 SL and other grids Full release Firestorm 5.0.1.52150OS 64 bit Intel Mac.dmg
SHA1 Checksum: 6AFC3235CE8C6444C839D017EBF8F230E9787A79
Linux
Linux
32-bit Havok
32 and 64 SL only X n/a n/a
Linux
32-bit OpenSim
32 and 64 SL and other grids Full release Firestorm 5.0.1.52150OS 32 bit Linux.tar.bz2
SHA1 Checksum: EBF63510B5CA251988984B14A62BECCB79C2FFF2
Linux
64-bit Havok
64-bit only SL only n/a n/a
Linux
64-bit OpenSim
64-bit only SL and other grids Full Release Firestorm 5.0.1.52150OS 64 bit Linux.tar.bz2
SHA1 Checksum: 93DDB7DCFB5554ED09B8BE4A24BD72EAAD1D2560

More information about the 64-bit builds can be found here.

Supported Operating Systems

Windows

  • Windows Vista 32bit SP2 and Vista 64bit SP2 or later are supported.
    Earlier versions of windows are not supported.
    This release is likely to be the last release that will run on Windows Vista so consider updating to at least Windows 7 if you are still using Vista.
  • Firestorm 5.0.1 will NOT even install on Windows XP.
  • Windows 10 - Firestorm 5.0.1 is compatible with Windows 10.
    However, if you are running Windows 10 on a system with an older Intel graphics card which does not support Windows 10 - Intel HD 2000, Intel HD 3000 or anything marked as “No” for Windows 10 on this list,
    you will only be able to run the 32bit versions of Firestorm 5.0.1 even if you have a 64bit version of Windows 10.
    Please see this page for detailed instructions if you are running Windows 10 on an older unsupported Intel card and have problems running Firestorm 5.0.1.

Mac

  • Mac 10.7 or later OS X versions are supported.
  • Mac PPC is not supported.
  • Firestorm 4.2.2 was the last version to support Mac 10.5, and is no longer available.
  • Firestorm 4.6.9 was the latest version to support Mac 10.6, and is no longer available.
  • Firestorm 5.0.1 viewer will NOT run on Mac 10.6.

Old Releases

Older versions of Firestorm are available here.


Additional Downloads to Fix Problems

Windows

  • Failure to launch or configuration errors at launch, please download this and install it, as your system likely needs MS C++ Runtime Libraries.
    • If you are on 32bit XP, you must have SP3 installed for this to work. Vista and windows 7 will work out of the box, though the latest SP is recommended.
  • App Fix Download Visual Studio C++ 2005 SDK dlls.
    • md5sum for AppFix.exe is abe1200dd50db8331cb69c0e94320b7e
  • SLURLs not working in your browser, or choose to open with a different viewer (Windows)


Additional Downloads to Enhance User Experience

Flash

Firestorm 5.0.1, 4.7.9 & 4.7.7 Release

  • Windows - Download in Firefox or Chrome to play Flash media inside Second Life.
    Choose the correct operating system under Step 1.
    Choose FP 23 for Opera & Chromium - PPAPI under Step 2.
    Install Flash.
  • Mac - Ensure that you have the most recent version of Flash for Safari installed. You an get this via the normal update process, or from Adobe.
    Choose the correct operating system under Step 1.
    Choose FP 23 for Safari and Firefox – NPAPI under Step 2.
    Install Flash.
  • Linux - You need to have the pepperflash plugin installed, which can be satisfied by installing Google Chrome.

Firestorm 4.7.5 and earlier, for all Operating Systems

  • Download to play Youtube videos inside Second Life.
    Do not use Internet Explorer when using that link. If Internet Explorer is the only browser you use, please ensure that you select Flash Player for Firefox, because the Internet Explorer version of Flashplayer is not compatible with any Second Life viewer.
    Windows 10 users may need to download the Windows 8 version of Flash for Firefox, if a Windows 10 version is not available.

Quicktime

Firestorm 5.0.1

  • Windows - Quicktime does not need to be installed to play media on Firestorm 5.0.1 or later.
  • Mac - Quicktime to play streaming videos. (iTunes is not needed)

GStreamer

for Linux only

  • Info for download to play streaming videos. (Please read page for info on installing GStreamer for your particular distribution.)

Growl

Linux has this already

  • Windows Download To get external notices about events when the viewer is minimized.
  • Mac Download To get external notices about events when the viewer is minimized.

DirectX Runtime

Windows only

  • DX runtime April 2011 to help increase performance and stability. For all versions of Windows. Please refer to this page.


Video Drivers

Mac drivers are included with OS upgrades. However, to determine what card you have, select “About this Mac” from the Apple menu, then click “More Info”. Under Hardware select Graphics/Displays.

If you are not sure what type of video card you have, use GPU-Z found (win only) here. For linux, in a console use:
lspci | grep VGA

Nvidia Video Driver

  • Latest driver Last checked Dec 12 - Windows: 376.19 (2016.12.5) - Linux: 375.20 (2016.11.18)

ATI Video Driver

  • Latest driver Last checked Dec 12 - Windows: Crimson ReLive Edition 16.12.1 (12/8/2016) - Linux: Linux Download Center
    NOTE: The 14.12 Omega driver has a bug which causes all rigged mesh to be invisible unless hardware skinning is disabled.
    We recommend that you use either the 14.9 Catalyst release or the 14.4 Catalyst release driver or the current 16.12.1 release driver. For further details, see Inara Pey's blog post.

Intel Video Driver

  • Intel driver download page Intel does not have a universal driver set. Please go to Intel's site and use the auto detect feature.


Source code

downloads.txt · Last modified: 2016/12/14 19:45 by whirly_fizzle