User Tools

Site Tools


fs_menus
Advertisement

Firestorm Top (Menu) Bar


Tip: clicking on the double lines will detach that menu, or sub menu, so it does not close automatically

Avatar Menu

  • Account: will prompt you to open your SL dashboard in a web browser
  • Marketplace Listings: Manage your SL marketplace listings.
  • Buy L$: opens the floater to let you buy L$
  • Inventory (Ctrl-I): opens your inventory
  • Picks: opens the Picks and Classifieds window for creation and editing of picks and classified ads.
  • Experiences: opens the Experiences window.
  • Profile: opens your profile
  • Appearance: opens the appearance floater at My Outfits (will be greyed out if you are a cloud; see here if that has happened to you)
  • Choose an avatar: opens the Choose an Avatar window.
  • Movement: opens the movement sub menu where you can set
    • Sit down (Alt-Shift-S): will sit your avatar down (not available if already sitting)
    • Fly (Home): this toggles will turn on fly mode (not available if sitting)
    • Stop Flying (Home): this toggle will turn off fly mode.
    • Always Run (Ctrl-R): toggles run
    • Force Ground Sit (Ctrl Alt S): This forces your avatar into a ground sit regardless of where your avatar is.
    • Move Lock (Ctrl-Alt-P): When enabled, will lock your avatar in place so it cannot be pushed.
      You will not be able to move yourself either, unless you enable PreferencesMove & View -> Movement → Lock and unlock position after stopping or starting movement.
    • Quickjump: If enabled, the viewer suppresses any pre-jump animation.
  • Move Controls: toggles the movement controls floater
  • Camera Controls: toggles the camera controls floater
  • Avatar Health: opens the Avatar Health sub menu
    • Stop avatar animations: used to stop animations acting on your avatar
    • Stop avatar animations & revoke permissions:
    • Undeform Avatar: Attempts to undeform your avatar, to recover its normal shape after deformation after the use of oversized avatars or griefer objects.
    • Force appearance update (Rebake)(Ctrl-Alt-R): rebakes your avatar's textures
    • Refresh Attachments: In cases where attachments are “ghosted”, it will attempt to reattach them. Ghosted attachments are those that shows attached to you but others don't see them.
    • Reset Default Male Avatar (Character Test): forces your avatar to the default male
    • Reset Default Female Avatar (Character Test): forces your avatar to the default female
    • Show Avatar Complexity Information:
    • Lag Meter: Opens the Lag Meter window.
    • Recreate LSL Bridge: creates a fresh copy of the LSL bridge
  • Snapshot (Ctrl-Shift-S): opens the snapshot floater
  • Money Tracker: Shows a list of who last paid you; see this page for more information.
  • Pose Stand…: Open the Pose Stand window; replicates the functionality of a pose stand.
  • Preferences (Ctrl-P): opens your preferences window
  • Toolbar Buttons: Opens the toolbar buttons window, allowing the button layout to be customized.
  • Show HUD Attachments (Alt-Shift-H): Shows all HUDs that you have attached
  • Exit Firestorm (Ctrl-Q): Closes Firestorm

Comm(unicate) Menu

  • Online Status: opens the Online Status sub menu where you can set yourself to:
    • Away
    • Unavailable (Busy)
    • Auto-respond: (the auto-response messages are set in PreferencesPrivacy -> Autoresponse)
    • Autorespond to non friends
    • Reject teleport offers and requests
    • Reject all group invites
    • Reject all friendship requests
  • Friends (Ctrl-Shift-F): opens the Friends tab in the contacts list.
  • Contacts (Ctrl-Alt-Shift-F): Opens or closes the contacts list.
  • Contact Sets (Ctrl-Alt-Shift-C): opens the Contact Sets window, to manage your own groups of contacts
  • Groups (Ctrl-Shift-G): opens the Groups tab in the contacts list.
  • Chat (Ctrl-H): opens the nearby chat tab in the Conversations window
  • People: Opens the people window.
  • Conversations (Ctrl-T): opens the Conversations window
  • Gestures (Ctrl-G): opens the Gestures window
  • Facebook…: opens the Post to Facebook window.
  • Twitter…: opens the Twitter window.
  • Flickr…: opens the Upload to Flickr window.
  • Voice Morphing:
  • Conversation Log: Opens the Conversation Log window.
  • Nearby Voice: opens nearby voice, aka active speakers
  • Block List: opens the people window → Block List

World Menu

  • Resync Animations: Restarts animations within your view; this allows couples dances to be resynchronized.
  • Nearby Avatars (Ctrl-Shift-A): Opens the Nearby tab in the People window.
  • Radar: Opens the Radar window.
  • Teleport History (Alt-H): Opens the Places window, teleport history tab.
  • Places: Opens the Places window.
  • Destinations: Opens up Destination window.
  • Events: Opens the SL Events web page.
  • Mini-Map (Ctrl-Shift-M): Opens the Minimap
  • World Map (Ctrl-M): Opens the World Map
  • Region Tracker: Opens the Region Tracker window.
  • Landmark This Place: Creates a landmark of your current location
  • Location Profile: Opens the Places Profile window
  • Parcel Details: Opens the About Land window
  • Region Details: Opens the Region/Estate window
  • Buy This Land: oOpens the Buy Land window (If you are on land that is not for sale, this will be greyed out)
  • Show Owned Land: Opens the Owned Land window
  • Show More: opens the Show More sub menu where you can chose to show
    • Ban Lines Enables or disables the ability to see ban lines around parcels to which you are not allowed access.
    • Beacons (Ctrl-Alt-shift-N) Hide/show beacons for some types of objects, like sound sources, particle sources, and so on.
    • Property Lines (Ctrl-Alt-Shift-P) Enables or disables showing lines at property boundaries.
    • Land Owners Colors land: Green is land owned by you, red is land owned by others, yellow is land for sale.
    • Coordinates: Shows your current coordinates in the menu bar
    • Parcel Permissions: Shows icons of your parcel rights
    • Advanced Menu (Ctrl-Alt-Shift-D): Hides/shows the Advanced Menu. This can also be done in PreferencesAdvanced.
  • Teleport Home (Ctrl-Shift-H): teleports you home
  • Set Home to Here: sets your home location to the point you are at; also saves a snapshot, which will be displayed when you log in to your home location.
  • Sun Position: opens the Sun Position sub menu, where you can set the sun position to
    • Sunrise (Ctrl-Shift-U)
    • Midday (Ctrl-Shift-Y)
    • Sunset (Ctrl-Shift-N)
    • Midnight (Ctrl-Shift-X)
    • Estate Time
  • Environment Editor: (Photographers might prefer that fast access available in QuickPrefs or Phototools) This has these sub-menus:
    • Environment Settings: Opens the environment settings window.
    • Water Presets: has sub-menus to allow water presets to be created, edited, deleted.
    • Sky Presets: has sub-menus to allow sky presets to be created, edited, deleted.
    • Day Presets: has sub-menus to allow day presets to be created, edited, deleted.
  • Photo and Video: opens the submenu for
    • Phototools (Ctrl-Alt-P): opens the Phototools floater.
    • Cameratools (Ctrl-Alt-C): opens the Cameratools floater.
  • Area Search: Opens the Area Search window
  • Sound Explorer: Opens the Sound Explorer window.
  • Animation Explorer: Opens the Animation Explorer window.
  • Asset Blacklist: Opens the Asset Blacklist Window.
  • Avatar Render Settings: Opens the Avatar Render Settings window.
  • Always show Friends normally: This will show all friends as normally rendered avatar instead of a “jelly doll” image.
  • Show Friends only: This will temporarily derender all avatars except those on your friends list. If you leave PreferencesMove & View -> Teleports → Keep 'Show Friends Only' enable after teleporting disabled, then this option will disable itself after teleport.

Build Menu

  • Build (Ctrl-B): opens the Build/Edit window
  • Select Build Tool: opens the Build Tool sub menu where you can select
    • Focus Tool (Ctrl-1)
    • Move Tool (Ctrl-2)
    • Edit Tool (Ctrl-3)
    • Create Tool (Ctrl-4)
    • Land Tool (Ctrl-5)
  • Link (Ctrl-L): will link multiple prims
  • Unlink (Ctrl-Shift-L): will unlink prims in a linkset
  • Edit Linked Parts: allows you to edit individual prims in a linkset
  • Select Elements: opens the Select Elements sub menu where you can choose:
    • Select Next Part (Ctrl-.)
    • Select Previous Part (Ctrl-,)
    • Include Next Part (Ctrl-Shift-.)
    • Include Previous Part (Ctrl-Shift-,)
  • Focus on Selection (H): will focus your camera on an object you have selected
  • Zoom to Selection (Shift-H): will zoom your camera on an object you have selected
  • Object: opens the Object sub menu that allows you to:
    • Take: Takes the object back to inventory
    • Take Copy: Creates a copy of the object in inventory.
    • Duplicate (Ctrl-D): Creates a duplicate of the object next to the original object.
    • Edit Particles: Opens the Particle Editor.
    • Save Back to Object Contents If you drag the contents of an object directly onto the ground (rather than into your inventory first, then out onto the ground), and make changes to it, this function allows those changes to be saved back to the original object.
    • Return Object Returns the object to the owner.
    • Save as:
      • Backup: Opens the Backup window, allowing you to save the object to your hard drive.
      • Collada: Opens the Collada Export window, which you can use to export the object as mesh.
  • Scripts: opens the Scripts sub menu where you can:
    • Show Script Warnings/Errors
    • Script Info (Counter): If the object is moddable, this will show script information for it.
    • Recompile Scripts (Mono)
    • Recompile Scripts (LSL)
    • Reset Scripts: this will only work if the object is moddable.
    • Set Scripts to Running
    • Set Scripts to Not Running
    • Remove Scripts from Selection: If the selected object is moddable, removes all scripts from it.
  • Pathfinding: Options concerning Pathfinding.
    • Region Objects: Opens the Region Objects window.
    • Characters: Opens the Pathfinding characters window.
    • View / Test: Opens the Pathfinding console.
    • Rebake Region: Rebakes the region NavMesh, if there are pending changes - assuming you have rights to do so and Pathfinding is enabled for the region; will by greyed out otherwise. This can also be done by clicking the Pathfinding icon in the top menu bar.
  • Options: opens the Options sub menu where you can:
    • Show Advanced Permissions: Refer to this SL Wiki page for more on Advanced (Debug) permissions.
    • Select Only My Objects
    • Select Only Movable Objects
    • Select Only Locked Objects
    • Select Only Copyable Objects
    • Select By Surrounding
    • Include Group-Owned Objects
    • Show Selection Outlines (Ctrl-Alt-H)
    • Show Hidden Selection
    • Show Light Radius for Selection
    • Show Selection Beam
    • Snap to Grid (G)
    • Snap Object XY to Grid (Shift-X)
    • Use Selection for Grid (Shift-G)
    • Grid Options (Ctrl-Shift-B)
    • Set Default Permissions: Opens the Default Creation Permissions window.
  • Upload: opens the Upload sub menu which allows you to choose what to upload (Same as the Upload item in the Avatar Menu):
    • Image (L$10): Opens a file selector, then the image upload window.
    • Sound (L$10): Opens a file selector, the the sound upload window.
    • Animation (L$10): Opens a file selector, then the animation upload window
    • Mesh Model: Opens a file selector to upload a mesh model; see the SL wiki for more info.
    • Bulk (L$10 per file): Opens a file selector where you can select multiple image files for upload.
    • Import Linkset: Opens the Import window, to upload a previous exported object.
  • Undo (Ctrl Z): will undo the last changes made in the edit /build window
  • Redo (Ctrl Y): will redo the last changes made with the undo command

Content Menu

  • Search (Ctrl-F): opens the Search window
  • SL Marketplace: prompts you to open the Marketplace web page
  • L$ Market Data: prompts you to open the L$ market Data web page
  • Script Library: prompts you to open the Script Library web page
  • Firestorm Blog: prompts you to open the Firestorm Viewer Home web page
  • Firestorm Flickr: prompts you to open the Firestorm Viewer Flickr web page
  • Firestorm YouTube: prompts you to open the Firestorm Viewer YouTube channel
  • Firestorm Twitter: prompts you to open the Firestorm Viewer Twitter web page
  • Firestorm Plurk: prompts you to open the Firestorm Viewer Plurk web page
  • Message of the day: this will show the message of the day in local chat. This also is shown during the login phase.

Help Menu

RLVa Menu

This menu is toggled from Advanced Menu (Ctrl-Alt-D) → RestrainedLove API (RLVa) or from Preferences → Firestorm → Extras → Allow Remote Scripted Viewer Controls (RLVa). This will require a restart of the viewer to show this menu.

  • Debug: Opens the Debug sub menu where you can enable:
    • Show Top-level RLVa Menu: Enables showing the RLVa menu in to menu bar. If disabled, RLVa menu will show in Advanced Menu.
    • Show Debug Messages: Used when debugging RLV scripts and also to know when something RLV is being done to you by either a person or object.
    • Hide Unset or Duplicate Messages
    • Show Assertion Failures
    • Hide Locked Layers
    • Hide Locked Attachments
    • Enable Legacy Naming
    • Enabled Shared Wear
    • Rename Shared Items on Wear
    • Locks: Opens the Active RLV Locks window
  • Allow OOC Chat: Allows Out Of Character (OOC) chat.
  • Allow Temporary Attachments
  • Forbid Give to #RLV
  • Show Filtered Chat
  • Wear Replaces Unlocked
  • Console: Opens the RLVa console window
  • Restrictions: Opens the Active RLV Restrictions window
  • Strings: Opens the RLVa Strings window

Advanced Menu

Please use with caution

This menu is toggled via the Ctrl-Alt-D key sequence, or from PreferencesAdvanced

  • Rebake Textures (Ctrl+Alt+R): (same as Avatar → Avatar health → Force Appearance Update).
  • Refresh Attachments:
  • Set UI Size to Default: Reverts any changes made in PreferencesUser Interface -> General → UI scaling.
  • Set Window Size: Allows you to set the window size.
  • Limit Select Distance: Limits your select distance to about 50m.
  • Disable Camera Constraints: Allows camera to pass through solid objects.
  • High-res Snapshot: Enables high resolution snapshots.
  • Quiet Snapshots: Disables the snapshot sound and animation.
  • Performance Tools: Opens the Performance Tools sub menu where you can enable:
    • Lag Meter: Opens the Lag Meter window.
    • Statistics Bar (Ctrl-Shift-1): Displays the Statistics window (often called the “stats bar”).
    • Scene Load Statistics (Ctrl-Shift-2): Displays the Scene Load Statistics window with focus on object load and cache performance.
    • Show Avatar Complexity Information: Displays an indicator of client draw “cost” above each avatar (replaces Avatar Rendering Cost).
  • Highlighting and Visibility: Opens the Highlighting and Visibility sub menu where you can choose:
    • Cheesy Beacon: Animates the red world map beacon to make it look “cheesy” (enable it to see the effect).
    • Hide Particles (Ctrl Alt Shift =) : Disables rendering of particles. Another way of achieving this is to go to PreferencesGraphics -> General and setting Max particle count to zero - or doing the same in the Quick Preferences panel.
    • Hide Selected: Makes the currently selected (edited) object invisible, until they are no longer selected.
    • Highlight Transparent (Ctrl Alt T): Makes transparent objects visible by highlighting them in red.
    • Show Mouselook Crosshairs
    • Hover Tips: Opens Hover Tips submenu
      • Show Tips (Ctrl-Shift-T): This allows you to set what hovertips, if any, you see (please check this first to enable hover tips)
      • Show Land Tooltips:
      • Show Tips On All Objects:
  • Rendering Types: Opens the Rendering Types sub menu, which allows types of things to be shown or hidden. By default, these are all enabled. Disabling some can be useful if you are trying to find a lost object.
    • Simple (Ctrl-Alt-Shift-1): Textures without alpha channels.
    • Alpha (Ctrl-Alt-Shift-2): Textures with alpha channels
    • Tree (Ctrl-Alt-Shift-3): Linden plants.
    • Avatars (Ctrl-Alt-Shift-4): Bodies and attachments but not name tags.
    • Surface Patch (Ctrl-Alt-Shift-5): Terrain/ground texture.
    • Sky (Ctrl-Alt-Shift-6): Entire sky including clouds and sun/moon.
    • Water (Ctrl-Alt-Shift-7): Water surface only, view when under water is still tinted.
    • Ground (Ctrl-Alt-Shift-8)
    • Volume (Ctrl-Alt-Shift-9): All objects except Linden plants.
    • Grass (Ctrl-Alt-Shift-0): Linden plants.
    • Clouds (Ctrl-Alt-Shift- -)
    • Particles (Ctrl-Alt-Shift-= )
    • Bump (Ctrl-Alt-Shift-\): Legacy bump map and shiny effects.
  • Rendering Features: Opens the Rendering Features sub menu:
    • UI (Ctrl-Alt-F1): Be VERY careful when using this, as the menu bar is hidden as well; make mental note of the key sequence so you can re-enable the UI when you need it.
    • Selected (Ctrl-Alt-F2): Display texture alignment crosshair boxes with “Select Face”.
    • Highlighted (Ctrl-Alt-F3)
    • Dynamic Textures (Ctrl-Alt-F4): Enable clothing and sculpt previews in texture upload floater.
    • Foot Shadows (Ctrl-Alt-F5)
    • Fog (Ctrl-Alt-F6)
    • Test FRInfo (Ctrl-Alt-F8)
    • Flexible Objects (Ctrl-Alt-F9): Enable/disable flexible prim effect.
  • RLVa: This will menu option will show if chose not to show RLVa menu in top menu bar. This will show RLVa submenus.
  • Media Streams Backup
    • Import Stream List XML: This will import the stream_list.xml file.
    • Export Stream List XML: This will export the media stream list from top menu → World Menu → Parcel DetailsSound tab to a file called stream_list.xml to a folder of your choosing
  • Use Plugin Read Thread: Uses a separate thread to read incoming messages from plugins. So in theory, this should give you a slight performance increase if you have a multicore processor and using the internal web browser or playing quicktime videos and so on.
  • Clear Group Cache: Clears group cache
  • Mouse Smoothing: Should help smooth mouse movement
  • Release Keys: Releases permissions taken by worn attachments.
  • Shortcuts: Opens the Shortcuts sub menu, showing some of the common keyboard shortcuts:
    • Search (Ctrl-F)
    • Show Advanced Menu-legacy shortcut (Ctrl-Alt-D)
    • DoubleClick Teleport (Ctrl-Shift-D)
    • Always Run (Ctrl-R)
    • Fly (Home)
    • Close Window (Ctrl-W)
    • Close All Windows (Ctrl-Shift-W)
    • Snapshot to Disk (Ctrl-`)
    • Mouselook (M)
    • Joystick Flycam (Alt-Shift-F)
    • Reset View (Esc)
    • Reset Camera Angles (Shift-Esc)
    • Look at Last Chatter (Ctrl-\)
    • Zoom In (Ctrl-0)
    • Zoom Default (Ctrl-9)
    • Zoom Out (Ctrl-8)
  • Fly Override (Ctrl-Alt-V): Allows flight in no fly areas - NOT recommended
  • RestrainedLove API: Enables/disables RLV (also in PreferencesFirestorm -> Extras → Allow scripted viewer controls)
  • Show Debug Settings: Opens the debug menu window; use with caution.
  • Show Develop Menu (Ctrl-Alt-Q): Shows or hides the develop menu on the menu bar.

Developer Menu

Please use with caution

This menu is toggled via the Ctrl-Alt-Q key sequence, or from PreferencesAdvanced

  • Consoles: Opens the Consoles sub menu. These should all be disabled in normal use. If you find your screen filling with “strange” graphs and data, check here to make sure all are off.
    • Texture Console (Ctrl-Shift-3):
    • Debug Console (Ctrl-Shift-4): Scroll activity log on the main viewer window.
    • Notifications Console (Ctrl-Shift-5): Trace dialogs, alerts, notifications.
    • Fast Timers (Ctrl-Shift-9): Shows tasks performed per frame.
    • Scene Statistics: Plot complexity of objects in view.
    • Scene Loading Monitor:
    • Region Debug Console Opens the Region Debug Console.
    • Region Info to Debug Console: Dumps region flags and stats to log
    • Group Info to Debug Console: Dumps summary of active group info to log.
    • Capabilities Info to Debug Console: Dumps capability names and URLs to log.
    • Camera: Camera and agent position/rotation overlaid on screen.
    • Wind: Region wind speed and heading is overlaid on screen.
    • FOV: Camera field of view angle overlaid on screen.
    • Badge (Ctrl-Alt-Shift-H) (This won't toggle off……)
  • Show Info: Opens the Show Info sub menu:
    • Show Time: Shows the time spent logged on in the lower right.
    • Show Upload Transaction: Gives a notification on upload, showing how much you were charged.
    • Show Texture Info: Shows texture information for the object under the cursor.
    • VRAM usage per object:
    • Show Avatar Render Info: Show load state and attachment weights for visible avatars.
    • Show Render Info: Displays information about the scene currently being rendered.
    • Show Matrices: OpenGL matrix info overlaid on screen.
    • Show Color Under Cursor: Shows the RGBA values for the color under the cursor, in the lower right.
    • Show Memory: Shows total viewer memory use overlaid on screen.
    • Show Private Mem Info: Private pool stats overlaid on screen.
    • Show Updates to Objects (Ctrl-Alt-Shift-U): Displays “clouds” of different colors when objects update.
  • Force an Error: opens the Force an Error sub menu. Using any of these will probably crash you. Aimed at viewer developers.
    • Force Breakpoint (Ctrl-Alt-Shift-B)
    • Force LLError And Crash
    • Force Bad Memory Access
    • Force Infinite Loop
    • Force Driver Crash
    • Force Software Exception
    • Force Disconnect Viewer
    • Simulate a Memory Leak
  • Render Tests: opens the Render Tests sub menu:
    • Camera Offset
    • Randomize Framerate: Add a random duration sleep with each rendered frame.
    • Periodic Slow Frame: Sleep half a second every 10 frames.
    • Frame Test: Capture buffer and pause.
    • Frame Profile: Dump GL stats to log.
    • Benchmark:
  • Render Metadata: Opens the Render Metadata sub menu; these are normally all disabled:
    • Bounding Boxes
    • Avatar Hitboxes
    • Normals
    • Octree
    • Shadow Frusta
    • Physics Shapes
    • Occlusion
    • Render Batches
    • Update Type
    • Texture Anim
    • Texture Priority
    • Texture Area
    • Face Area
    • LOD Info
    • Build Queue
    • Lights
    • Particles
    • Collision Skeleton
    • Joints
    • Raycast
    • Wind Vectors
    • Render Complexity
    • Attachment Bytes
    • Sculpt
    • Texture Size
    • Texture Density
      • None
      • Current
      • Desired
      • Full
  • Rendering: Opens the Rendering sub menu
    • Axes: Draw XYZ axis display centered on avatar plus region origin marker.
    • Tangent Basis
    • Selected Texture Info Basis (Ctrl-Alt-Shift-T): Show size and alpha channel presence for faces selected in editor.
    • Selected Material Info (Ctrl-Alt-Shift-M):
    • Wireframe (Ctrl-Shift-R): Show object geometry.
    • Object-Object Occlusion (Ctrl-Shift-O): Optimization, skip rendering objects that are hidden behind others.
    • Advanced Lighting Model: Enable deferred rendering.
    • Debug GL: Enable extra OpenGL error checking.
    • Debug Pipeline: Subset of Debug GL.
    • Automatic Alpha Masks (deferred): Force alpha test instead of blend if texture has little transparency (when advanced lighting on).
    • Automatic Alpha Masks (non-deferred): Force alpha test instead of blend if texture has little transparency (when advanced lighting off).
    • Animation Textures: Allows texture to be animated per llSetTextureAnim.
    • Disable Textures: Stop fetching new textures from the network.
    • Full Res Textures (dangerous): Disregard LOD and display all textures at full resolution. Increases network and memory use.
    • Render Attached Lights: Render local light sources on avatar attachments.
    • Render Attached Particles: Render particle systems emitted by avatar attachments.
    • Hover Glow Objects:
  • Network: Opens the Network sub menu:
    • Pause Agent: Stop avatar movement updates. Local turns and interpolated motion will still appear.
    • Enable Message Log: Dump every protocol message to log.
    • Disable Message Log: Stop protocol message dump.
    • Velocity Interpolate Objects: When enabled it allows smoothed object motion between updates and for llTargetOmega motion to work. When it's disabled, stops “rubber band” effect at cost of these features.
    • Ping Interpolate Object Positions: Factor ping time into interpolation.
    • Drop a Packet (Ctrl-Alt-L): Simulate loss of a data packet.
  • Dump Scripted Camera
  • Recorder: opens the Recorder sub menu. This is used to record, and then playback, a sequence of your actions. For example, you can record yourself walking round, then when you play it back, your avatar will repeat that exactly. Useful for machinima.
    • Start Playback
    • Stop Playback
    • Loop Playback
    • Start Record
    • Stop Record
  • World: Opens the World sub menu:
    • Sim Sun Override
    • Fixed Weather
    • Dump Region Object Cache: Send object cache statistics to log.
    • Dump Simulator Features to Nearby Chat
  • UI: Opens the UI sub menu:
    • Media Browser Test: Opens embedded browser with Viewer URI Name Space test page.
    • Region Restart Test:
    • Web Content Browser (Ctrl-Shift-Z): Opens the internal browser.
    • FB Connect Test: For checking Second Life Share API.
    • Dump SelectMgr: Info about selected objects to log.
    • Dump Inventory: Inventory UUIDs and names to log.
    • Dump Timers: Function call stats to log.
    • Dump Focus Holder: What UI element has keyboard focus to log.
    • Print Selected Object Info (Ctrl-Shift-P): Object details to log.
    • Print Agent Info (Shift-P): Avatar name and camera to log.
    • Double-Click Auto-Pilot
    • Double-Click Teleport
    • Debug SelectMgr: If this and Limit Select Distance are active, dump auto deselects to log.
    • Debug Clicks: Mouse button changes with coordinates to log.
    • Debug Views: Identify UI elements on screen.
    • Debug Name Tooltips: Identify XUI source for UI element under cursor. (alias of Show XUI Names)
    • Debug Mouse Events: Info about what has mouse focus to log.
    • Debug Keys: Text entry field activity to log.
    • Debug Window Process: Low level info for main viewer window to log.
  • XUI: opens the XUI sub menu:
    • Reload Color Settings: Refresh from skin's colors.xml
    • Show Font Test: Open floater with type specimen.
    • Load from XML
    • Save to XML
    • Save XUI Names: Identify XUI source for UI element under cursor.
    • Show debugging info for views
    • XUI Preview Tool
    • Send Test IMs: Send dummy messages to test accounts.
    • Flush Names Caches: Clean avatar name cache.
  • Avatar: Opens the Avatar sub menu:
    • Grab Baked Textures
      • Iris
      • Head
      • Upper Body
      • Lower Body
      • Skirt
    • Character Tests
      • Appearance To XML: Saves your avatar shape to a file; opens a file picker to allow you to select the destination folder, and file name. Shapes exported this way can be re-imported in the Appearance window.
      • Toggle Character Geometry
      • Test Male: Shortcut to wear “Male Shape & Outfit” from inventory Library/Clothing.
      • Test Female: Shortcut to wear “Female Shape & Outfit” from inventory Library/Clothing.
      • Allow Select Avatar: Avatars can be selected and “moved” with object editor, local effect only, movements do not appear to others.
    • Animation Speed
      • All Animations 10% Faster
      • All Animations 10% Slower
      • Reset All Animations Speed
      • Slow Motions Animations
    • Force Params to Default: Clear and refresh tweakable appearance settings.
    • Animation Info: Text over avatars with running animations and priorities.
    • Show Look At: Shows look at crosshairs.
    • Show Point At: Show destination for selection beam as a red crosshair.
    • Debug Joint Updates: Rapid summary of updates to log.
    • Disable LOD: For avatar bodies.
    • Debug Character Vis: Dump avatar and attachment visibility to log.
    • Show Collision Skeleton: Show avatar's “collision volume” joints. Used with fitted mesh and touch/select. Not used with simulator physics.
    • Show Bones:
    • Display Agent Target: Crosshairs with avatar's actual and rendered positions.
    • Dump Attachments: Attachment points, UUIDs, positions, visibility to log.
    • Debug Avatar Textures (Ctrl-Alt-Shift-A): Shows component textures for own avatar.
    • Dump Local Textures (Alt-Shift-M): Avatar texture info to log.
    • Reload Avatar Cloud Particle:
  • Compress Images: Select a file and convert to .j2c, results to log.
  • Enable Visual Leak Detector:
  • Output Debug Minidump
  • Console Window on next Run: Opens a window on the next run of the viewer, which shows internal information as the viewer runs. Useful for developers' to debug the viewer. Otherwise, keep this disabled.
  • Set Logging level: This allows the level of detail of logging to be changed from the default (Info). The support team might request that you change this if attempting to diagnose a problem; otherwise, it should always be left at default.
    • Debug
    • Info
    • Warning
    • Error
    • None
  • Request Admin Status (Ctrl-Alt-G): Request privileges. Only works if you are a Linden.
  • Leave Admin Status (Ctrl-Alt-Shift-G)
  • Show Admin Menu

Searching the Menus

It is possible to search the menus for specific words or phrases, by typing into the search bar at the top. For example, typing in the word upload will result in matches on up to four top menu items: Avatar, Build, Advanced and Develop. In short, using search will filter out what is shown in the top menu bar, removing all items except those that contain what you searched for.

Matched items are highlighed in color (you can change the highlight color in Preferences → Colors -> Miscellaneous → Preferences Search Highlight Color).

To clear the search, and have the Preferences window revert to its normal state, just click the 'x' at the far right end of the search field.

Menu search is enabled (or disabled) in Preferences -> Advanced → Show Menu Search.

Graphics Presets

: When hovering your mouse over this symbol, it will open the Graphics Presets window. Please note that this symbol will only show if you have created a graphic preset in PreferencesGraphics -> General.



See this page for documentation on Firestorm 5.0.1 (52150) and earlier.

fs_menus.txt · Last modified: 2017/06/21 02:34 by miro.collas